9: Re: Formatting Tables (response to 6)
Posted by Alan-Parry (Euphonix Admin). on

Hi Helen

Again trial and error.  I didn't know the answer so I have experimented on my private test page.

Suggest you set up the table using the system (again setting the width to 100% (as described above)).  In Table properties (General tab) I created a table comprising 4 columns & 10 rows.  Against Cell Padding I set a figure of 20 and in Cell Spacing I also used 20.  I then opened the Advanced Tab, so I could monitor where the border was in relation to the input text I set the Border Colour to #000000 (in other words black).

If the table is not displayed then do not dispair.  You may find it has been concertinered into a single square blob on the left-hand side if the screen.  With your mouse carefully left-click where you think the top left-hand cell should been and add some text (eg. "qwerty"), then using your tab key go to the next "bunched up" cell and repeat adding text, and so on until the whole table is revealed.

Once the table was created and using the right-hand mouse button I clicked the 1st top left-hand cell; this brings up a menu.  Because I wanted in this instance for all the cells to be of equal size I went down the drop-down menu to Cell and then Table Cell Properties and in the width box I set a figure of 25% and above the Update Box I used the dropdown menu to pick Update all cells in the table (4 columns at 25% each = 100%).

Now my table had been set up I needed to test whether the padding had worked.  I needed to put some text in the cells (I used some gibberish - Qwerty 1234.) I just hightligthed this gibberish text and using the "crtl+C keys" made a copy of it.  Then to insert my gibberish text I used the "crtl+v" keys repeatedly to paste the copied text several times into each cell to test how it would look when published.  In reality it didn't matter what I typed as it was never going to be published.  When you add text into the cells it looks like it is right up against the borders of the cell and that one cell's text runs into the adjoining cell.  When you are inputting data you may get doubts about the cell padding.  Fear not as this is not the case.  When I saved the page with my table full of gibberish text and then previewed it there was a definite space between the text in each of the cells and the black border.

Hopefully, you'll get the same results.

PS.  If you don't want the black border outlining the table or cells return to the Advance Tab in Cell Properties and remove the colour code #000000.

PPS.  If you want a distinctive border then in table properties set the Border box to a number probably greater than 3 but less than 10.

Let me know how you get on.

10: Re: Formatting Tables (response to 9)
Posted by Eileen Murray on

Thanks for the comprehensive response, Alan, I'll give it a go tomorrow. E x

11: Re: Formatting Tables (response to 10)
Posted by Eileen Murray on

Hi Alan. Didn't work for me. Only an outer frame, cell padding in all bar the first columns - but there are a few other "funnies" about how my test table is displaying that is making me wonder about possible settings in the CSS framework our website developer might have put in, so I'll go and "bother" her for some tuition...... Thanks again. Eileen x

12: Re: Formatting Tables (response to 11)
Posted by Alan-Parry (Euphonix Admin). on

Hi Eileen,

If you got some cell padding then you must almost be there.

Try going back into your table and this time select a cell that doesn't have the padding and put in the same numbers into the Table Properties that you used for the successful cell.  Then when go to Update make sure you select from the dropdown menu the update all cells in the table option.

It's all about trial and error.  I hadn't needed cell padding in the couple of tables that I have, so your question was a new challenge.  For me it was all about experimentation to find out the limits of the system.  But after several attempts I got the cell padding worked out.  It didn't look like it was working when I was inputting data, but when I went to Preview and then Publish the cell padding was certainly there.

Anyway good luck.

All the best,


13: Re: Formatting Tables (response to 12)
Posted by Eileen Murray on

Thanks Alan.....will persevere....E x

16: Re: Formatting Tables (response to 12)
Posted by Eileen Murray on

Hi Alan - I got my answer during a session with our resident e-voice guru today. I needed to go into the table's general properties and set the Class to "Table". All sorted now. There is such a long list of classes I didn't think to mess with that one! E x

17: Re: Formatting Tables (response to 16)
Posted by Alan-Parry (Euphonix Admin). on

Hi Eileen,

Now you have taught me something.

Thanks for the update

All the best