Bug Reports: Private Membership Policy site still allowing users to apply

Hi,

My site (Bracondale Residents' Association) is set to a Membership Policy of as Private (Invitation Only). However people still seem to be able to request membership and I get an email with a link for approval. If I approve the user then they become a member of the site.

My expectation is that with Private Membership, users should not be able to request to join the site and I that I should have to generate an invitation for them to join. I would not expect the Sign-Up link to appear in the login page of a Private site.

Can you suggest what is happening please. FYI the site was at one time set to Closed but was switched to private some months ago.

Thanks

Dave

Ahhah - so I think the problem here is that a user can end up requesting membership of your site by following the register link on the login page.

I see that the link to join the site is correctly removed, but I believe that if a user registers using the form on your site (rather than the equivalent registration form on the main e-voice site) they will automatically get membership of your site requested from you.

We can't remove the Login button completely (because site owners need to use this to be able to edit the site), but maybe if a site is Private then either the Register link isn't available, or if they click on it it would just take them to the main registration page for e-voice, and not the one for your site.

Do you think this sounds sensible?

Thanks

Joe - Voice Admin

Posted by DaveP on

Sorry - Just discovered that this was not posted back in July. I had just replied to the email.

 

Hi Joe,

Yes you have understood the issue. Your proposal of removing the Register link from the site login page is the correct one in my view. I cannot see that there are any side effects to that.

Many thanks for looking at this.

Dave